Главная > Linux > Asbru: Ошибки GLib-LOG setenv/putenv are not thread-safe and should not be used after threads are created

Asbru: Ошибки GLib-LOG setenv/putenv are not thread-safe and should not be used after threads are created

04.02.2021 0 коммент. » Просмотры: 104

Asbru Logo

После одного из обновлений, где-то пол-года назад начал получать ошибки вида "GLib-LOG setenv/putenv are not thread-safe and should not be used after threads are created" сразу после создания окна с терминалом в Asbru. На тот момент я решения не нашел, но тк сами ошибки не на что не влияли, а появлялись только при инициализации окна, я их попросту игнорировал, до сегодня..

По какой-то причине обратив на них внимание сегодня, решил поискать решение опять, и нашел его.

Для начала вот так выглядели ошибки у меня

Объяснение проблемы и решение нашел вот тут: https://github.com/asbru-cm/asbru-cm/issues/432

Для Kubuntu решается установкой новой версии Glib, сделать это можно так

После этого перезапускаем Asbru и проблема исчезает.

Похожие статьи

Автор: | Рейтинг: 4/5 | Теги: , ,

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Разрешены HTML-теги: <a>, <code>, <i>, <em>, <strong>, <b>, <u>, <strike>