Главная > Linux > CentOS, WMWare Tools: The path "" is not a valid path to the kernel headers.

CentOS, WMWare Tools: The path "" is not a valid path to the kernel headers.

11.04.2015 0 коммент. » Просмотры: 2 540
 

VMWare Tools

Последние пару дней тестирую всякие системы виртуализации. Сегодня при попытке установить VMWare Tools в CentOS столкнулся с такой проблемой:

Searching for a valid kernel header path...
The path "" is not a valid path to the 3.10.0-229.el7.x86_64 kernel headers.
Would you like to change it? [yes]

При этом после выполнения

Я получил ту же ошибку, т.к. установилась не нужная мне версия, а именно вот эта : kernels/3.10.0-229.1.2.el7.x86_64 ..

Поискав решение в интернете нашел следующее, на stackexchange:

После выполнения, этот команды, у меня появилась нужная папка:

/usr/src/kernels/3.10.0-229.el7.x86_64/

Осталось только указать её в скрипте установки. Обратите внимание, что нужно добавить папку include, т.е. указывать надо:

/usr/src/kernels/3.10.0-229.el7.x86_64/include

Ну, и напоследок, быстро найти версии которые у вас установлены можно такой командой:

 

Автор: | Теги: ,

Важно

У нас заработал ФОРУМ. Все вопросы, которые не касаются статьи, а так же вопросы по конкретно вашему случаю нужно задавать и обсуждать именно там, в разделе "Помощь пользователям".

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Разрешены HTML-теги: <a>, <code>, <i>, <em>, <strong>, <b>, <u>, <strike>