Главная > Linux | Бездна | Сервера | Хостинг > Certbot: ACMEv1 is deprecated and you can no longer get certificates from this endpoint

Certbot: ACMEv1 is deprecated and you can no longer get certificates from this endpoint

20.07.2021 0 коммент. » Просмотры: 80

Во время обновления бесплатного сертификата от LetsEncrypt столкнулся с с ошибкой: ... ACMEv1 is deprecated and you can no longer get certificates from this endpoint ...

Полный текст ошибки при запуске "certbot renew"

Processing /etc/letsencrypt/renewal/site.com.conf
Cert is due for renewal, auto-renewing…
Plugins selected: Authenticator webroot, Installer None
Attempting to renew cert (site.com) from /etc/letsencrypt/renewal/site.com.conf produced an unexpected error: urn:acme:error:serverInternal :: The server experienced an internal error :: ACMEv1 is deprecated and you can no longer get certificates from this endpoint. Please use the ACMEv2 endpoint, you may need to update your ACME client software to do so. Visit https://community.letsencrypt.org/t/end-of-life-plan-for-acmev1/88430/27 for more information.. Skipping.

Сходил по ссылке и прочитал что пора переходить на протокол ACMEv2 вместо ACMEv1 используемый для авторизации веб-сайтов.

Решил обновить certbot клиента, и это решило проблему. Делается вот так

после обновления на версию 0.27.0, все сертификаты обновились как и ожидалось. Осталось перезапустить Nginx

И все начало работать 🙂

Похожие статьи

Автор: | Рейтинг: 4/5 | Теги: ,

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Разрешены HTML-теги: <a>, <code>, <i>, <em>, <strong>, <b>, <u>, <strike>