Главная > Linux > Черный экран после обновления до Ubuntu 18.04

Черный экран после обновления до Ubuntu 18.04

17.08.2018 0 коммент. » Просмотры: 68

Завершение процесса в Линукс

Пару дней назад я решил обновиться до Ubuntu 18.04. Но, как часто бывает, столкнулся с проблемой, а именно после перезагрузки я получил черный экран, без признаков жизни..

Прежде всего, я подождал..

Немного подождал

Немного подождал

Через пару минут ничего не происходило и я решил действовать, попробовал переключиться на терминал через Ctrl+Alt+F1, ничего не произошло. Затем я попытался понажимать Ctrl+C, мало ли где-то там за черным экраном, меня о чем-то спрашивают, но нет и это не помогло. Тогда я решил перезагрузиться, но Ctrl+Alt+Del не реагировали. Приплыл..

Ну и что теперь делать?

Ну и что теперь делать?

Перезагрузился с помощью Reset - та же история...

Т.к. работал grub (у меня стоит еще Windows и появляется диалог выбора ОС), я попробовал добавить параметр nomodeset в аргументы запуска, чтобы исключить проблему с драйверами видеокарты -  не помогло, все тот же черный экран..

Что за фигня?

Что за фигня?

В общем, еще пара экспериментов и перезагрузок через кнопку reset все тоже самое, и тут я случайно во время черного экрана нажал кнопку Delete, вжуууух и появился лог загрузки

Жми Delete когда нет других вариантов

Жми Delete когда нет других вариантов

В логе была надпись:

A start job is running for Raise newtwork interfaces (3min 2s / 5 min)

Время соответственно увеличивалось, после того как прошло 5 минут, такая же фигня вылезла опять. Я решил немного подождать и посмотреть, что будет дальше, т.к. судя по ошибке "оно" пыталось дождаться запуска сетевых интерфейсов, а их у меня 2 (2-е встроенные сетевые карты). И я был прав, после 10 минут (!!!) ожидания, комп загрузился.

Ну долго еще?

Ну долго еще?

Теперь предстояло разобраться с проблемой, полез я в гугл. В итоге выяснилось что в файле конфигурации интерфейсов, вместо auto eth0 надо теперь писать allow-hotplug eth0.

  • открываем файл интерфейсов sudo nano /etc/network/interfaces
  • ищем наши интерфейсы и меняем им auto eth0 (имя может быть другое, например eno1 или enps16s0) на allow-hotplug eth0
  • для localhost интерфейса менять не надо, т.е. auto lo, так и оставляем.

Разница в том, что auto пытается запустить интерфейс в момент загрузки, а allow-hotplug после получения события "интерфейс определен через  udev hotplug api" или "подключен кабель". Лично я предполагаю, что в момент загрузки появилась какая-то проблема с очередностью загрузки драйверов материнки, потому и нет связи с карточками, а после они уже детектятся и интерфейсы поднимаются нормально, но это так, предположения..

Сохраняемся и отправляем комп в перезагрузку и .. получаем сообщение о отключении карточек..

A stop job is running for ifup for enp16s0 (52s / 1min 33s)

Ну, уже знаем что к чему, ждем... Перезагружаемся. Все стартует за пол-минуты, как и ожидалось..

Ну, наконец-то

Ну, наконец-то

 

Похожие статьи

Автор: | Рейтинг: 4/5 | Теги: , , ,

Важно

У нас заработал ФОРУМ. Все вопросы, которые не касаются статьи, а так же вопросы по конкретно вашему случаю нужно задавать и обсуждать именно там, в разделе "Помощь пользователям".

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Разрешены HTML-теги: <a>, <code>, <i>, <em>, <strong>, <b>, <u>, <strike>