Главная > Linux > Flash Player в Firefox Ubuntu 16.04

Flash Player в Firefox Ubuntu 16.04

14.11.2016 0 коммент. » Просмотры: 1 470
 

Flash player

Понадобилось мне на одном из сайтов воспроизводить Flash. К сожалению, версия поставляемая с Firefox была слишком стара, из-за того, что в начале 2012 года Adobe перестала полноценно поддерживать плагин..

Вот, это сообщение из блога Adobe:

For Flash Player releases after 11.2, the Flash Player browser plugin for Linux will only be available via the “Pepper” API as part of the Google Chrome browser distribution and will no longer be available as a direct download from Adobe. Adobe will continue to provide security updates to non-Pepper distributions of Flash Player 11.2 on Linux for five years from its release.

Однако, как сказано в сообщении, поддержка остается в виде "Pepper API", который предоставляет поддержку Flash-а в браузере Chromium. Однако, в моем случае, хотелось бы получить поддержку не в Chromium, а в Firefox.

Т.к. Linux - это ооочень большое сборище энтузиастов, то я предположил, что уже кто-то сделал нужный пакет. После недолгих поисков он был найден и называется freshplayer.

Для установки вам необходимо сделать следующее:

1) Включить Canonical Partners репозитории, для этого открываем файл /etc/apt/sources.list:

ищем где-то в конце и расскоментируем строчку "deb ..", чтобы получилось так

и сохраняемся

2) теперь обновляем кеш пакетов:

3) установливаем adobe-flashplugin

4) устанавливаем freshplayer-pepperflash

После этого, требуется:

  • Открыть Firefox
  • Зайти в Tools > Add-ons
  • Перейти на вкладку Plugins
  • Для всех плагинов Shockwave Flash {версия}, в выпадающем списке устанавливаем "Always activate"
  • Перезапускаем браузер

После этих манипуляций, Flash заработал как и ожидалось

Автор: | Теги: , ,

Важно

У нас заработал ФОРУМ. Все вопросы, которые не касаются статьи, а так же вопросы по конкретно вашему случаю нужно задавать и обсуждать именно там, в разделе "Помощь пользователям".

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Разрешены HTML-теги: <a>, <code>, <i>, <em>, <strong>, <b>, <u>, <strike>