Главная > Linux > Kubuntu 18.04: Перестал работать PAC Manager

Kubuntu 18.04: Перестал работать PAC Manager

19.08.2018 0 коммент. » Просмотры: 98

PAC Manager IconВ качестве терминального клиента использую PAC Manager. К сожалению, после обновления Kubuntu до версии 18.04, он перестал запускаться. Нечто похожее у меня уже было: PAC: Ошибка Vte.so: undefined symbol, поэтому я попробовал переустановить его по этой же инструкции, но это не помогло..

Насколько я смог понял PAC не мог запустится из проблем в файле /opt/pac/lib/ex/vte64/auto/Gnome2/Vte/Vte.so  Этот файл пердставляет из себя символическую ссылку на библиотеку Vte.so_64_5.022. В интернете советуют просто удалить эту ссылку. Я попробовал это сделать, и PAC запустился. Однако, как и следовало ожидать, он зависал при попытке совершить подключение к удаленному серверу.

Я нашел целых два решения. Первое заключается в установке libgnome2-vte-perl_0.11-1_amd64.deb, который я нашел тут (если первоисточник перестанет работать, то я сделал бэкап файла)

После этого надо переименовать/удалить символическую ссылку /opt/pac/lib/ex/vte64/auto/Gnome2/Vte/Vte.so

После этого PAC начинает нормально работать.

Другой способ использовать snap пакет: pac-vs

Этот способ лучше чем первый, т.к. snap-пакеты включают в себя сразу все зависимости, а это уменьшает кол-во багов при следующем обновлении. Однако, при такой установке, не будет нативной стилизации приложения, поэтому я выбрал первый вариант.

--[добавлено]--

Если при запуске получаете сообщение, что нужно установить libgtk2-appindicator-perl, то сделать это можно так

 

Похожие статьи

Автор: | Рейтинг: 4/5 | Теги: ,

Важно

У нас заработал ФОРУМ. Все вопросы, которые не касаются статьи, а так же вопросы по конкретно вашему случаю нужно задавать и обсуждать именно там, в разделе "Помощь пользователям".

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Разрешены HTML-теги: <a>, <code>, <i>, <em>, <strong>, <b>, <u>, <strike>