X

Kubuntu 18.04: Перестал работать PAC Manager

В качестве терминального клиента использую PAC Manager. К сожалению, после обновления Kubuntu до версии 18.04, он перестал запускаться. Нечто похожее у меня уже было: PAC: Ошибка Vte.so: undefined symbol

В качестве терминального клиента использую PAC Manager. К сожалению, после обновления Kubuntu до версии 18.04, он перестал запускаться. Нечто похожее у меня уже было: PAC: Ошибка Vte.so: undefined symbol, поэтому я попробовал переустановить его по этой же инструкции, но это не помогло..

Насколько я смог понял PAC не мог запустится из проблем в файле /opt/pac/lib/ex/vte64/auto/Gnome2/Vte/Vte.so Этот файл пердставляет из себя символическую ссылку на библиотеку Vte.so_64_5.022. В интернете советуют просто удалить эту ссылку. Я попробовал это сделать, и PAC запустился. Однако, как и следовало ожидать, он зависал при попытке совершить подключение к удаленному серверу.

Я нашел целых два решения. Первое заключается в установке libgnome2-vte-perl_0.11-1_amd64.deb, который я нашел тут (если первоисточник перестанет работать, то я сделал бэкап файла)

wget -O libgnome2-vte-perl_0.11-1_amd64.deb https://packagecloud.io/asbru-cm/asbru-cm/packages/ubuntu/bionic/libgnome2-vte-perl_0.11-1_amd64.deb
sudo dpkg -i libgnome2-vte-perl_0.11-1_amd64.deb

После этого надо переименовать/удалить символическую ссылку /opt/pac/lib/ex/vte64/auto/Gnome2/Vte/Vte.so

sudo mv /opt/pac/lib/ex/vte64/auto/Gnome2/Vte/Vte.so /opt/pac/lib/ex/vte64/auto/Gnome2/Vte/Vte.so.bak

После этого PAC начинает нормально работать.

Другой способ использовать snap пакет: pac-vs

sudo snap install pac-vs

Этот способ лучше чем первый, т.к. snap-пакеты включают в себя сразу все зависимости, а это уменьшает кол-во багов при следующем обновлении. Однако, при такой установке, не будет нативной стилизации приложения, поэтому я выбрал первый вариант.

--[добавлено]--

Если при запуске получаете сообщение, что нужно установить libgtk2-appindicator-perl, то сделать это можно так

wget -O libgtk2-appindicator-perl_0.15-1build5_amd64.deb http://mirrors.edge.kernel.org/ubuntu/pool/universe/libg/libgtk2-appindicator-perl/libgtk2-appindicator-perl_0.15-1build5_amd64.deb
sudo dpkg -i libgtk2-appindicator-perl_0.15-1build5_amd64.deb ; sudo apt-get -f install

Категории: Linux
Тэги: pacubuntu

Комментарии (2)

  • Привет! Спасибо, твоя статья помогла. Достало искать на англоязычных сайтах информацию по pac manager. Столкнулся с такой же проблемой как и у тебя. Я использую версию Ubuntu Mate, а он не понмает что такое "dpkg " и первый вариант у меня не пошел, но пошел второй вариант. И пока работает. Надеюсь, статья твоя будет еще висеть в интернете. Всякое бывает, вот надо, и как всегда нет инфы. Еще раз спасибо, очень помогля статья твоя!

    • Привет! Веду свой блог именно по причине того, что находишь полезную инфу, по тому или иному вопросу, а потом статья исчезает или сайт закрывается. Так что, если нахожу решение своих проблем, стараюсь дублировать сюда. Да, и в целом, рад тому, что кому-то мои статьи экономят время :) Спасибо за отзыв!