Главная > Magento > Magento 2: Please update your modules: Run "composer install" from the Magento root directory.

Magento 2: Please update your modules: Run "composer install" from the Magento root directory.

21.04.2019 0 коммент. » Просмотры: 82

Magento 2

Столкнулся с такой ситуацией, когда версия дампа старше версии кодовой базы. В итоге при попытке запуска Magento 2 получил ошибку

Усугубляло это еще то, что я использовал PHP 7.2, и при попутке запустить рекомендуемый composer install я получал сообщение о не поддерживаемой версии php..

ну Ок, мне по прежнему лень даунгрейдить PHP.. Вариант №1, отрубаем проверку версий вот тут:

вот так

Думаю, должно быть понятно, что это решение не для продакшена, а только для локальной разработки, когда надо срочно поднять magento, чтобы исправить какие-то небольшие баги в не родных модулях..

В общем, правим так, попросту игнорируя ошибки и все начинает работать..

Но, есть и другой способ, вычленяем название модулей и их версии из текста ошибки, у меня это

открываем табличку setup_module и правим ручками значения, ставим версии из кодовой базы.

Например для модуля Magento_Cron ставим "2.0.0" вместо "2.0.0.1", было

Версия Magento_Cron

стало

Модуль Magento_Cron

Модуль Magento_Cron

Повторяем для всех упомянутых в ошибке.

После этих манипуляций все начинает работать.

 

Похожие статьи

Автор: | Рейтинг: 4/5 | Теги: , ,

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Разрешены HTML-теги: <a>, <code>, <i>, <em>, <strong>, <b>, <u>, <strike>